SMS are currently unable to send out
Incident Report for RentProfile
Resolved
This incident has been resolved.
Posted May 26, 2022 - 22:41 BST
Investigating
We have contacted our SMS provider about this.
Posted May 26, 2022 - 16:29 BST
This incident affected: Agent dashboard, myRentProfile, API, and Mobile applications.