Agent Dashboard unavailable for a small number of clients

Incident Report for RentProfile

Resolved

This incident has been resolved.
Posted Aug 24, 2023 - 12:11 BST

Investigating

We are currently investigating this issue.
Posted Aug 24, 2023 - 11:45 BST
This incident affected: Agent dashboard.