Maintenance
Incident Report for RentProfile
Resolved
Maintenance has been completed.
Posted Oct 10, 2021 - 20:53 BST
Identified
General maintenance has started. During this time some RentProfile services may be unavailable.
Posted Oct 10, 2021 - 20:07 BST
This incident affected: Agent dashboard, myRentProfile, API, and Mobile applications.